ファイル操作

Q: ファイルを検索したい
Q: 自動的にバックアップデータを保存したい
Q: 分析に使用したメソッドファイル,バッチファイル,チューニングファイル等を確認したい
Q: データファイルからメソッドファイルを復元したい
Q: データファイルからバッチファイルを復元したい
Q: 1つのデータファイルのサンプル名,サンプルID,コメントを変更したい
Q: 複数のデータファイルのサンプル名,サンプルID,コメントを変更したい
Q: 1つのデータファイルをASCII変換したい
Q: 複数のデータファイルをASCII変換したい
Q: データファイルをAndi(AIA)形式に変換したい
Q: CLASS-5000のデータファイルをGCMSsolution用データファイルに変換したい
Q: 複数のCLASS-5000のデータファイルをGCMSsolution用データファイルに変換したい
Q: 複数のデータファイルを一括でASCII,AIA(Andi),JCAMP,mzData,mzXML形式に変換したい
Q: ファイルを検索したい(お問い合わせ番号0812)
A: メソッドファイルやデータファイルなどをどこのフォルダに保存したか忘れてしまったとき,ファイル名や分析した日時などで検索し,簡単に見つけ出すことができます。
1. [GCMS再解析]ウィンドウで,[ファイル]メニューの[ファイル検索]を選択します。 [SHIMADZU GCMSファイル検索]画面の[名前と場所]タブで,[ファイル名],[ファイルタイプ],[探す場所]に入力し,[検索開始]ボタンで検索できます。
[日付]タブで分析日時や更新日時での検索,[その他]タブで[分析者名]や[サンプル名]での検索もできます。

[SHIMADZU GCMSファイル検索]画面

2. 検索結果は,画面左下のリストビューに表示されます。 [ファイル情報]チェックボックスと[TIC プレビュー]チェックボックスのどちらかをチェックして(同時にチェック不可)、各種情報を確認できます。

[ファイル検索結果]画面



説明資料:
gcms812.pdf
(627kB,会員制サイト)
Q: 自動的にバックアップデータを保存したい(お問い合わせ番号0811)
A: 分析したデータファイルを指定のフォルダに自動的にバックアップすることができます。

[GCMS分析]ウィンドウの分析アシスタントバーの[データ採取]アイコンをクリックします。
[ツール]メニューの[オプション]をクリックし,[オプション設定]画面を開きます。 [自動コピー]タブで自動コピーするタイミングとコピー先のフォルダの設定をします。 設定後,[OK]ボタンをクリックします。

[オプション設定]画面
説明資料:
gcms811.pdf
(749kB,会員制サイト)
Q: 分析に使用したメソッドファイル,バッチファイル,チューニングファイル等を確認したい(お問い合わせ番号0809)
A: GCMSsolutionで取得したデータファイルには,分析に使用したメソッドファイル,バッチファイル,チューニングファイル等が記録されています。

1. [GCMS再解析]ウィンドウで,[ファイル]メニューの[データファイルを開く]でメソッドなどを確認したいデータファイルを開きます。
2. [ファイル]メニューの[データファイルのプロパティ]を選択します。 〔プロパティ〕画面の[使用したファイル]タブでデータファイルで使用したファイルが表示されます。
これらの情報は編集できません。 ファイル名が表示されていない項目は登録されていないものです。

[データファイルのプロパティ]画面



説明資料:
gcms809.pdf
(551kB,会員制サイト)
Q: データファイルからメソッドファイルを復元したい(お問い合わせ番号0801)
A: GCMSsolutionで採取したデータファイルには,メソッドファイルが記録されています。もしメソッドファイルを誤って消失しても,データファイルからメソッドファイルを復元することができます。

1. [GCMS再解析]ウィンドウで,[ファイル]メニューの[データファイルを開く]で復元したいメソッドで採取したデータを開きます。
2. [ファイル]メニューの[メソッドに名前をつけて保存]を選択します。 保存するメソッドファイル名を入力し保存します。 データを採取した時と同じ内容のメソッドファイルが作成されます。

参考:データファイルから分析に使用した環境設定を確認したい
   データファイルから分析に使用した分析条件を確認したい
説明資料:
gcms801.pdf
(667kB,会員制サイト)
Q: データファイルからバッチファイルを復元したい(お問い合わせ番号0810)
A: GCMSsolutionで採取したデータファイルには,バッチファイルの内容が自動的に記録されています。 もしバッチファイルを誤って消失しても,データファイルからバッチファイルを復元することができます。

1. [GCMS再解析]ウィンドウで,データ解析画面を表示します。 [ファイル]メニューの[データファイルを開く]で復元したいバッチスケジュールを使ったデータを開きます。
2. [ツール]メニューの[データ中のバッチテーブルに名前をつけて保存]をクリックし,[バッチテーブルの選択]画面を開きます。 [再解析時のバッチテーブル]か[データ採取時のバッチテーブル]のどちらかにチェックを入れ,[OK]ボタンで画面を閉じます。

[データファイルのプロパティ]画面

[バッチファイルに名前をつけて保存]画面が開くので,名前を入力し保存します。
バッチファイルが復元されたことはデータエクスプローラ等で確認してください。
説明資料:
gcms810.pdf
(624kB,会員制サイト)
Q: 1つのデータファイルのサンプル名,サンプルID,コメントを変更したい(お問い合わせ番号0802)
A: データ取得前のサンプル登録時に,データファイルのサンプル名やサンプルIDを入力しますが,データ取得後,これらを修正することができます。

1. <データファイルの読込>
[GCMS再解析]ウィンドウで,[ファイル]メニューの[データファイルを開く]でサンプル名やIDを変更したいデータを開きます。
2. <データのプロパティでサンプル情報変更>
[ファイル]メニューの[データファイルのプロパティ]を選択します。 [プロパティ]画面で,[サンプル情報]タブに現在開いているファイルのサンプル登録情報が表示されています。 [サンプル名]/[サンプルID]/[内標量]/[サンプル量]/[希釈率]を変更できます。 
これらの情報のうち,サンプル量,希釈率は検量線の作成,定量計算に用いられますから,必ず設定するようにしてください。 さらに,サンプルタイプが未知試料で内部標準法を使って定量計算をするときは内標量の設定も必要です。
3. <データのプロパティでコメントの変更>
[コメント]タブで開いているデータファイルのコメントが表示され,コメントの編集ができます。 変更後,[OK]ボタンをクリックし画面を閉じます。
4. <変更内容の確認>
データエクスプローラ等でサンプル名,サンプルIDが修正されたことを確認できます。 データエクスプローラで,1.で読込んだサンプル情報を変更したデータファイル以外のデータファイルを選択後,再度1.で選択したデータファイルを選択すると修正されたことが確認できます。
説明資料:
gcms802.pdf
(608kB,会員制サイト)
Q: 複数のデータファイルのサンプル名,サンプルID,コメントを変更したい(お問い合わせ番号0803)
A: データ取得後,バッチスケジュールを用いると複数のデータについてまとめてサンプル名,サンプルID,コメントを修正することができます。

1. <バッチテーブルの作成>
[GCMS再解析]ウィンドウで,[ポストラン]アシスタントバーの[バッチ処理]アイコンをクリックします。
サンプル名やサンプルIDを修正するためのバッチテーブルを作成します。 これまでGCMS分析などで使用したバッチファイルがある場合は,それを利用します。
各行の[データファイル]に修正したいファイルを選択します。
2. <サンプル情報/コメントの変更>
[サンプル名]/[サンプルID]/[コメント]にそれぞれ入力します。 修正するファイルの各行について,[解析の種類]をクリックし,[データ処理]画面で全てのボタンをOFFし[OK]ボタンで画面を閉じます。
バッチスケジュールを開始するとデータ処理をせず,サンプル名,サンプルIDが変更されます。 データエクスプローラ等でサンプル名,サンプルIDが修正されたことを確認できます。
説明資料:
gcms803.pdf
(537kB,会員制サイト)
Q: 1つのデータファイルをASCII変換したい(お問い合わせ番号0804)
A: ASCII変換するとデータ処理の結果をテキスト形式で出力することができます。出力されたテキストファイルはメモ帳や市販のスプレッドシートアプリケーションで簡単に見ることができます。

1. [ファイル]メニューの[データファイルを開く]でASCII変換したいデータを開きます。
2. [ファイル]メニューの[データのエクスポート]を選ぶと[データのエクスポート(ASCII変換)]が開きます。
3. <出力ファイル名と出力項目の設定>

[データのエクスポート(ASCII変換)]画面
[クリップボードにコピー]か[ファイルに出力]のどちらかを選択します。 ファイルに出力する場合,出力先とファイル名を入力します。 [出力項目]からASCII変換したい項目を選びチェックし,最後に[区切り記号]を選択し(Tabが一般的),[OK]ボタンをクリックするとASCII変換を行います。
4. < ASCII変換したファイルの確認>
ASCII変換したファイルができたかの確認は,[データエクスプローラ]で確認できます。タブを[すべてのファイルタブ]にして,3.で作成したテキストファイルが表示されているか確認してください。
説明資料:
gcms804.pdf
(919kB,会員制サイト)
Q: 複数のデータファイルをASCII変換したい(お問い合わせ番号0805)
A: 複数のデータファイルもバッチテーブルを使えば,一括でASCII変換できます。

1. <バッチファイルの読込>
[GCMS再解析]ウィンドウ左側のアシスタントバーから[バッチ処理]アイコンをクリックします。 [ファイル]メニューの[バッチファイルを開く]でASCII変換したいファイルが登録されているバッチファイルを開きます。バッチファイルが無い場合は,ASCII変換を行うファイルを再解析するバッチファイルを,新規に作成します。
2. <バッチテーブルに項目追加>
バッチテーブル上で右クリックし,右クリックメニューから[テーブルスタイル]を選択します。 [テーブルスタイル]画面の[カラム順序の設定]タブで[非表示にするアイテム]から[ユーザープログラム]を選び,[追加]をクリックします。設定後,[OK]で画面を閉じます。
3. < ASCII変換処理の設定>
バッチテーブルのASCII変換を行うファイルの[ユーザープログラム]セルをクリック,[矢印]ボタンをクリックします。 [ユーザープログラム]画面で[データ処理後]チェックボックスをオンにします。 [プログラムファイル]で,ASCII変換後に出力するプログラム(Excelなど)を選択します。
[パラメータ]の[矢印]ボタンをクリックし,[ASCII変換ファイル]を選択します。([パラメータ]に"%ASCIIFILE%"と入力されます。) [動作]は[プログラムが終了するまで待機する]か[プログラムが起動したらすぐ次の行を実行する]を選択し,画面を閉じます。
4. <出力ファイル名の設定>
[バッチ処理]アシスタントバーの[設定]アイコンをクリックし,[設定]画面を開きます。 [ASCII変換]タブで,[ASCIIファイルの出力]チェックボックスをオンにします。 [バッチ終了時に出力]か[各分析毎に出力]から選択します。 保存するフォルダを選択し,出力ファイルの名前を入力します。ファイル名は[上書き]か[自動番号]から選択します。  [出力項目]を選択し,[区切り記号]でASCIIファイルで項目を分ける文字を指定し画面を閉じます。
5. <バッチ処理の実行>
上記設定後,バッチ処理を行うとバッチスケジュール終了後にASCIIファイルが作成されます。 Excelに出力する設定していると,データの処理後Excelが自動起動しファイルが表示されます。
説明資料:
gcms805.pdf
(909kB,会員制サイト)
Q: データファイルをAndi(AIA)形式に変換したい(お問い合わせ番号0806)
A: データファイルをAndi(AIA)形式に変換すると他社製GC/MSデータ解析ソフトにGCMS-QP2010シリーズで採取したデータファイルを読み込ませることが可能です。 Andi形式とは,米国分析工業会(AIA)規定のMS共通データ形式です。
他社のGC/MSのデータファイルとGCMS-QP2010シリーズのデータの比較が可能になりますが,生データだけの移動なので,これまで行ったデータ処理結果は反映されません。

1. <ファイルの読込>
[GCMS再解析]ウィンドウで〔ポストラン〕アシスタントバーの[定性処理]アイコンを選択して,データ解析画面を表示します。 [ファイル]メニューの[データファイルを開く]で変換したいデータを開きます。
2. < AIA(ANDI)変換の設定 >
[ツール]メニューの[オプション]を選択します。 〔オプション設定〕画面が開くので,[AIA(Andi)変換]タブで〔変換モード〕を選択します。

〔オプション設定〕画面

バックグラウンドノイズのように低い強度でランダムに変動するようなクロマトグラムでは,マイナス強度になる場合があります。 このマイナス値をそのままAIA変換して他のソフトウェアで読み込むと,そのソフトウェアがマイナス値をサポートしていない場合エラーになる可能性があります。 そのことを考慮の上,変換モードを選択してください。
3. <データファイルを保存>
[ファイル]メニューの[データファイルに名前をつけて保存]を選択し,ファイルの種類で[AIA(Andi)ファイル(*.cdf)]を選択して,名前を入力して保存します。
説明資料:
gcms806.pdf
(632kB,会員制サイト)
Q: CLASS-5000のデータファイルをGCMSsolution用データファイルに変換したい(お問い合わせ番号0807)
A: CLASS-5000で作成したデータファイル(計算データファイル,生データファイル)やメソッドファイルはGCMSsolutionで読み込んで使用することができます。 
CLASS-5000のデータファイル(拡張子.d??)と解析データファイル(拡張子.r??)形式のファイルが同一フォルダに存在する場合は,CLASS-5000で行った再解析も保存されます。(データファイルのみの場合は,CLASS-5000で行ったデータ処理結果は反映されません。)

補足)
CLASS-5000形式のデータファイル(拡張子.d??)は,直接GCMSsolutionで開くことができます。 データファイルを開く際に,GCMSsolution内部で自動的にGCMSデータファイルに変換して,再解析画面などに読み込まれます。
但し,CLASS-5000で作成したデータファイルやメソッドファイルをバッチ処理で使用する場合は,GCMSsolution形式に変換しないと使えません。


1. <ファイルの読込>
[GCMS再解析]ウィンドウで〔ポストラン〕アシスタントバーの[定性処理]アイコンを選択して,データ解析画面を表示します。 [ファイル]メニューの[データファイルを開く]で,〔ファイルの種類〕を[CLASS-5000データファイル(*,D??)]を選択し,変換したいデータを開きます。
2. <データファイルの保存>
画面上にデータが表示されます。 [ファイル]メニューの[データファイルに名前を付けて保存]を選択し,ファイルの種類が[GCMSデータファイル(*,qgd)]であることを確認し,名前を付けて保存します。
注)CLASS-5000形式のデータファイルを変換すると面積値などの値に丸め誤差が生じることがあります。
ピーク検出のアルゴリズムの改良により,CLASS-5000のときよりも計算したピークトップの位置が多少ずれる場合があります。
説明資料:
gcms807.pdf
(585kB,会員制サイト)
Q: 複数のCLASS-5000のデータファイルをGCMSsolution用データファイルに変換したい(お問い合わせ番号0808)
A:
1. <データファイルの選択>
[GCMS再解析]ウィンドウで〔データエクスプローラ〕の[すべてのファイル]タブをクリックし,CLASS-5000形式のファイルを選択(複数選択可)します。 選択したファイル上で,右クリックし,[ファイル変換]を選択します。

〔データエクスプローラ〕

2. <データファイルの変換>
〔CLASS-5000ファイルを新しい形式のファイルに変換〕画面の〔選択ファイルリスト〕には,1.で選択されたファイル群からGCMSsolutionファイルフォーマットに変換可能なCLASS-5000形式ファイルが抽出され表示されます。 (選択されたファイル群中にCLASS-5000形式のファイルがない場合には,選択ファイルリストに表示されません。)
変換ファイルを保存するフォルダを指定し, [OK]ボタンをクリックすると変換作業を開始します。 ファイル名はCLASS-5000で使用していたファイル名になります。

〔CLASS-5000ファイルを新しい形式のファイルに変換〕画面

変換作業中に作業を中断するときは,ファイル変換状況ダイアログの[中断]ボタンをクリックしてください。  [中断]ボタンが押されるまでに変換されたファイルは,指定されたフォルダに生成されています。

〔CLASS-5000ファイルを新しい形式のファイルに変換〕画面
説明資料:
gcms808.pdf
(600kB,会員制サイト)
Q: 複数のデータファイルを一括でASCII,AIA(Andi),JCAMP,mzData,mzXML形式に変換したい(お問い合わせ番号0813)
A: 複数のデータファイルを一括で様々なファイル形式(ASCII,AIA(Andi),JCAMP,mzData,mzXML)に変換することができます。
注:Ver.2.70以降でお使いいただける機能です。 それ以前のVer.の場合,バージョンアップが必要です。

1. <変換したいファイルとファイル形式を選択>
[GCMS再解析]ウィンドウのデータエクスプローラ上で変換したいファイルを選択し,右クリックします。 メニューの[ファイル変換]を選択し,変換したいファイル形式を選択します。

[データエクスプローラ]

2. < ASCIIファイルに変換する場合>
[GCMSsolutionデータファイルをASCII形式に変換]画面が開きます。
データエクスプローラ上のフォルダを選択し,[出力項目]をクリックすると,[出力項目]画面が表示されるので,ASCII変換したい項目を選び,チェックします。 最後に[区切り記号]を選択し(Tabが一般的),[OK]ボタンをクリックします。
[GCMSsolutionデータファイルをASCII形式に変換]画面の[OK]ボタンをクリックするとASCII変換を行います。

[GCMSsolutionデータファイルをASCII形式に変換]


同じようにAIA(Andi)形式に変換する場合は,[GCMSsolutionデータファイルを AIA(Andi)形式に変換]画面が開きます。 データエクスプローラ上のフォルダを選択し,[OK]ボタンをクリックするとAIA(Andi)変換を行います。
3. <変換したファイルの確認>
変換したファイルができたかの確認は,[データエクスプローラ]で確認できます。 タブを[すべてのファイルタブ]にして,2.で作成したテキストファイルが表示されているか確認してください。
説明資料:
gcms813.pdf
(919kB,会員制サイト)

Excel®,は,米国マイクロソフト社の登録商標です。

Top of This Page