IRsolution Version 1.60SU1 Readme

2011年7月
(株)島津製作所

このドキュメントには IRsolution Version 1.60SU1 に関する重要な情報が含まれています。

IRsolution Ver.1.60からの変更点
IRsolution Ver.1.50SU3からの変更点
IRsolution Ver.1.40からの変更点
IRsolution Ver.1.60での注意点

不具合情報につきましては、認証後ダウンロードいただけるようになっております irs160su1cd.zip の中の readme.htm でご確認ください。

IRsolution Ver.1.60からの変更点

IRsolution Ver.1.60SU1ではIRsolution Ver.1.60から以下の点が修正されました。

1

バリデーションプログラムのJP16/EP7.0への対応

日本薬局方バリデーションプログラムを従来の第十五改正日本薬局方(JP15)対応から第十六改正(JP16)対応に、ヨーロッパ薬局方バリデーションプログラムをヨーロッパ薬局方6.0(EP6.0)対応から7.0(EP7.0)対応に変更しました。 なお、どちらのプログラムも検査内容に変更は無く、出力されるレポートのタイトルに記載される改正番号の略称がそれぞれ「JP16」、「EP7.0」に変更されています。

IRsolution Ver.1.50SU3からの変更点

IRsolution Ver.1.60ではIRsolution Ver.1.50SU3から以下の点が修正されました。

1

Windows 7への対応

新しいOSであるWindows 7上での動作に対応しました。

IRsolution Ver.1.40からの変更点

IRsolution Ver.1.50ではIRsolution Ver.1.40から以下の点が修正されました。

1

Windows Vistaへの対応

新しいOSであるWindows Vista上での動作に対応しました。
2

付属マクロプログラムの日本語対応

測定メニュー内の項目名や、動作中の画面のうち日本語化未対応だった部分が対応しました。
3

付属マクロプログラムの単位表記

ASTM、JP、EPのバリデーションプログラムの印刷出力上で、単位の「cm-1」や縦軸表記の「%T」などがタイトル行に追記されるようになりました。
4

スペクトル検索アルゴリズムの追加

スペクトル検索のアルゴリズムとして、ベースラインの傾いたスペクトルに対してもより有効な、「適合一次微分差」と「一次微分相関」が追加されました。
5

再構成コマンドの追加

検索メニューに、編集したライブラリの項目番号を整える「再構成」コマンドが追加されました。
6

インストール時初期パラメータの変更

インストール直後の測定パラメータを、より実用性の高い構成に変更しました。

検索
1
複数のサドラーライブラリを選択して検索したとき、印刷で "Sadtler Note"項目が出力されないという不具合が修正され、印刷可能となりました。

付属マクロプログラム
1
ASTMバリデーションでノイズ計算のための設定波数が誤っている箇所がある不具合が修正されました。
2
EPバリデーションで印刷出力上のスペクトルの縦軸表記が「%T」となっている箇所が、「ABS」に訂正されました。
3
異物解析プログラムにおいて、データフォルダがCドライブ以外に設定されていると、制限ユーザが実行したとき途中で停止する不具合が修正されました。
4
一部のプログラムで、印刷時に文字化けが発生する不具合が修正されました。

IRsolution Ver.1.60での注意点

IRsolution Ver.1.60では使用にあたって以下の注意点があります。

プログラム全般
1
スクリーンセーバー
繰返し測定やマッピング測定時など測定中にスクリーンセーバーが作動すると、ソフトウェアが停止する場合があります。スクリーンセーバーは使わないようにOSを設定してください。
2
IRsolution は、Windows Explorer によるデータファイルのダブルクリックによる表示に対応しておりません。
3
いくつかのヘルプボタンやメニューで正しい項目でなく、"IRsolutionの概要"ページを開く場合があります。それらを参照する必要がある場合、[ヘルプ]-[ヘルプ] を選択して、コマンドリファレンスを参照してください。
4
マッピングなどの長時間にわたる測定中にコンピュータが省電力またはスタンバイモードに入ると、IRsolutionがフリーズする場合があります。 長時間測定を行なう必要がある場合には、省電力設定やスタンバイモード設定をオフにしてください。
5
検索パラメータ画面がフロート状態になっているときに表示タブ画面に移り、再度検索画面に移ると検索パラメータ画面が表示されないことがあります。
6
一旦保存したスペクトルを開いた場合、もしグラフ設定で線色を変更していても、印刷時にその色設定は使用されません。
7

IRsolution1.50をアンインストールするとき、"Sadtler DBCOM SDK uninstall program"と表示されますが、これは表示の不具合で、継続すればIRsolution 1.50が正常にアンインストールされます。

8

スペクトルデータファイルのサイズが非常に大きい場合や開いている数が多い場合には、データ処理やファイルのオープン/クローズに十数分程度を要し、その間、表示画面の一部が白くなったり、背景の壁紙が透けて見えたりする場合があります。

9

実行ファイル"IRsolution.exe"のプロパティを表示したときなど、IRsolutionのアプリケーション名が内部名の"HyperIR"と表示されることがありますが、動作には問題ありません。

10

誤って日本語版以外のSUをIRsolution Ver.1.50に対してインストールすると、アンインストールしてから再インストールしても、改ざんチェックが不合格となる場合があります。

11

IRsolutionはWindows7のAero(エアロ)機能に対応していませんので、Aero機能はご使用にならないようにお願いします。

ファイル関連
1 データファイルの日付に関する注意
IRsolution で使用する smf ファイルはデータベース構造をとっており、ファイルへの書き込みの有無に関わらず、ファイルにアクセスするたびにファイルの日付が更新されます。従って、 IRsolutionでファイル使用中にはストレージ上のデータファイルの日付は更新されていきます。 そのため IRsolution では検索などでの日付による絞込みに不都合が発生しないように、メモリデータに変更がなされていない場合はデータクローズ時に日付を元に戻すように設計し ております。 何がしかの変更がなされている場合は新しい日付になります。
2 Active Data Pointer の扱いに関して
IRsolution のツリービューでデータセットをダブルクリックすることによりActive Data Pointer を変更した場合、アクティブデータポインタの変更はデータファイルに上書き記憶されます。ただし、この場合、データに変更があったとはみなしません。 IRsolution Agent をご使用の場合、Active Data Pointer の変更によってデータは登録されません。
3

IRsolution version 1.04と1.10およびそれ以降のバージョンでのデータファイル互換性
IRsolution Version1.04で測定・作成されたデータはIRsolution Version1.10およびそれ以降のバージョンで読み込むことができます。しかし、IRsolution Version1.10およびそれ以降のバージョンで測定・作成されたデータはIRsolution Version1.04で読み込むことはできません。最新のバージョンのIRsolutionにバージョンアップするか、[ファイル]−[エクスポート] 機能でsmfフォーマット以外のデータに保存してからIRsolution Version1.04で読み込んでください。

4 フロッピードライブを使用したデータ保存及び読み込みロード
フロッピードライブにIRsolution からデータを保存/ロードする場合、データファイル容量の4倍から5倍の空き容量を持たせるようにしてください。ファイル作業中にはフロッピーディスクを 一時的に作業領域として使用するためです。 又、GLP モードでIRsolution を動作させる場合、フロッピーディスクにデータを置いて操作することは適切ではありません。 GLP モードの場合、処理ごとにデータファイルに保存が行われます。フロッピーディスクの容量不足、処理速度の遅さ、などの理由でデータを失う事態が起こる可能 性があります。
5 [ファイル]-[カタログ] 機能で、ファイルの種類に全てを選択した時、IRsolution に関連のないファイル例えばテキストファイルなどは開けませんのでご注意ください。
6 [ファイル]-[カタログ]のオプション機能にある『OR』オプションが正しく働きません。
7 csvフォーマットのデータをIRsolutionで読み出してsmfに変換したスペクトルは、データ処理画面に表示されずデータ処理ができない場合があります。一度、JCAMP-DXフォーマットに変換してください。

測定メニュー/測定関連
1 測定タブでスペクトル画面にマウスを動かすと文字入力ができなくなります。
測定時には、拡大領域の移動を矢印キーの移動で行なう機能が作り込まれており、一旦グラフ領域にマウスが移動した後は全てのキーボード入力をグラフが取りこんでしまいます。 グラフからカーソルが出た場合でも既にエディットボックスはフォーカスを失っておりますので、文字入力はできません。測定タブでファイル名などの変更を行なう場合はグラフ以外の場所にマウスを移動してください。
2 各種マクロに関するご注意
ASTM, EP/JP などのマクロを動作させる場合、前もって FTIR を初期化する必要があります。 初期化されていない状態でマクロを動作させた場合、装置によっては、プログラムがロックする現象があります。装置を初期化後にマクロを使用してください。 また、 マクロプログラムはバックグラウンドの表示をONにした状態で使用していただきますようお願いします。
3 Easy Scan マクロに関して
Easy Scan マクロは、約10分以内に終了する測定に関してのみ有効です。 典型的な分解能での測定可能な積算回数はおおよそ次のとおりです。
分解 1 cm-1 選択時 積算 120回
分解 4 cm-1 選択時 積算 450回
4 測定データファイル名に、"."(コロン)を使用した場合には、(例えば test-2002.11.05)コロン以降が拡張子として認識されます。
5 測定データファイル名に、"/"を使用した場合には、(例えば test-2002/11/05)ファイル名が正しく認識されません。 測定は可能ですが、ファイル名として不適切な為、データが未保存状態となります。測定ファイル名には"/"を使用しないでください。
6 ユーザー管理で測定パラメータの変更を禁止した場合でも、 Easy Scan マクロでは幾つかの測定パラメータの変更が可能です。 (分解、積算など) GLP/GMP環境でIRsolutionを使う場合、社内 SOP でこれらに関しては制限していただきますようお願いします。
7 レポートビューワーについて
IRsolution 1.04ならびにIRsolution 1.10 SU2でASTM ValidationやJPEP2000 Validationを0時から10時までの間に行なった場合、 Report ViewerのInspected dayに表示される日時が異常になります。この不具合はIRsolution 1.10 SU2およびそれ以降のバージョンに含まれるプログラムでは修 正されていますが、これまでに測定された結果の表示は修正できません。
(例)実施時刻 9時32分20秒 Inspected dayの表示 93時22分
8 積算途中で測定を中止してもパラメータの「測定」タグ内は設定した積算回数値が表示されます。履歴欄を参照してください。
9 しきい値測定の設定(IFGノイズ、類似性)が正常に動作しない場合があります。
10 付属品認識機能付きの付属品をIRPrestige-21に搭載したまま、電源を入れて初期化すると、付属品は認識するが、「使用可能なメソッド」を表示する画面が現れません。
11

連続測定を、少ない積算回数、低分解の測定条件で行なった場合、指定回数よりも少ないデータしか測定できない場合があります。これは、 コンピュータ(ソフトウェア)の処理速度を超えてデータがFTIRから送られてくるために受取れない場合が生じるためです。このような状況が起きない典型 的な測定条件は以下のとおりです。積算回数はこれよりも多くしてください。

分解 0.5cm-1のとき、積算 5回
分解 1cm-1のとき、積算 5回
分解 2cm-1のとき、積算 5回
分解 4cm-1のとき、積算 5回
分解 8cm-1のとき、積算 10回
分解 16cm-1のとき、積算 10回

12 バリデーションプログラム(ASTM Level 0/JP/EP)を実行するときは、『連続測定』のチェックマークをはずしてください。
13 FTIR-8400Sにおいて、option3に検出器を接続していない場合でも、パラメータ設定画面で検出器をoption3、ミラー 速度を9.0mm/s、分解を2.0cm-1以上に設定すると、それぞれのパラメータがstandard、2.8mm/s、4.0cm-1に相当する測定 が実行されてしまいますので、パラメータ設定時にはご注意ください。
14 FTIR-8400Sにおいて、分解を0.5cm-1にするなど、使用できないパラメータ設定をした状態で装置の初期化を実行すると、パ ラメータ設定ドロップダウンリストが空白になり、正しいパラメータを設定できなくなります。初期化は仕様にある設定をした状態で行ってください。
15

メモリ搭載量の少ない古いPCで、オートサンプラーを利用した測定を実行すると、測定数が多くなるにつれ速度が遅くなり、画面更新に時間がかかるようになることがあります。

16

「IRPrestige-21」および「IRAffinity-1」に対して、「自己診断」コマンドを選択した際の画面において、現状では「N2」の有無が検出できないため、その項目が削除されました。

17

Windows 7環境では、ステータス画面上の、各項目の状態を表す色つき四角形がちらつくことがあります。

データ処理
1 ピークリストをフロート状態で表示している時に、タブを移動するとピークリストウインドウに描画問題が起こり、グラフなどがピークリスト 画面上に張り付くことがあります。ウインドウサイズを変更するなどして、ピークリストウインドウの再描画を促すことで画面は更新されます。
2 ピーク検出パラメータ画面において、ノイズレベルは保存されませんのでご注意ください。
3 ピークテーブルに対する コピー/貼り付け によって、テーブルの編集が可能になっておりますが、本機能は使用しないでください。
4 [データ処理1]-[膜厚計算]を実行する際、スペクトル上のノイズを干渉縞と判断する場合があります。
5 [データ処理2]-[FFT]で、波数範囲に最大波数<最小波数と入力し計算を実行しても計算は実行されません。最大波数>最小波数となるように入力し直して計算を実行してください。
6 [データ処理2]-[FFT]で、波数範囲に最大波数=最小波数と入力して計算を実行すると、4000-400cm-1の範囲のフーリエ変換を実行します。
7 クラマース・クローニッヒ変換後のスペクトルに対し波形分離を行なうと分離後のピークなどが表示されません。
8 [データ処理2]-[波形分離]で、パラメータを変えて何回か計算を試行した後にOKボタンをクリックすると、最終の結果とともに試行の結果もファイルに保存され、ツリービューに表示されます。
9 [データ処理2]-[波形分離]を実行した場合、詳細レポートが作成されません。
10 [データ処理2]-[波形分離]で、波数範囲に最大波数=最小波数と入力しても計算は実行されません。
11 [データ処理2]-[波形分離]で、透過率スペクトルに対して波形分離を行なうと、縦軸単位を自動的に吸光度に変換します。
12 [データ処理2]-[波形分離]で、データのない領域に処理波数領域を設定すると、IRsolutionがアプリケーションエラーを起こすことがあります。
13 [データ処理2]-[波数-波長変換]で、もし波数軸の最小値が0.00cm-1であるようなデータを使用すると、データ間隔の設定が異常な値となることがあります。
14 ピーク検出でピークの追加と削除を何度も繰り返すと、アプリケーションエラーが発生することがあります。

検索
1
検索タブで、Join Visible を ON/OFF する際に、ヒットリストの表示が更新されない場合があります。
この現象が出た場合にはヒットリスト右横にあるスクロールバーで、ヒットリストをスクロールすることにより画面は正常に書き直されます。
2
テキスト検索/複合検索に関するご注意
現在のバージョンでは検索メニューでテキスト検索/複合検索を行なう場合には、複数のライブラリを選択することはできません。
3
検索パラメータウインドウをドッキングしていない状態で表示し、他のタブへ移り、その後検索ウインドウに戻ると、パラメータウインドウの表示が更新されない場合があります。 パラメータウインドウをクリックするなどして描画更新を行ってください。
4
スペクトル検索のヒットスペクトルをsmfファイルとして保存した場合、 ツリービュー上で、表示のクリアを行なうと問題が起きる場合があります。 smfファイルへの エクスポート後にはエクスポートしたファイルのクリアを行わないでください。

5

検索においてサドラーライブラリで複合検索を行なうと検索対象データが自動的に規格化され保存されます。
6
サドラーライブラリのSTを使用してテキスト検索および複合検索をAll以外のキーワードで検索するとエラーになります。
7
csvフォーマットのデータをIRsolutionで読み出してsmfに変換したスペクトルを用いて検索をした場合、正常に検索されません。ヒットしたスペクトルの表示も異常になります。
8 ヒットリストの列の長さは変更できません。
9 スペクトル検索を実行後、ツリービューのコンテキストメニューで「ヒットリストに表示」を選択すると、スペクトルを規格化せずに表示するので、縦軸範囲が合いません。
10 スペクトル検索後、ツリービューの検索したスペクトルのコンテキストメニューから、「ヒットリスト上で検索」を行なうと、検索パラメータの一部分が使用できなくなる場合があります。
11 スペクトル検索後、ヒットリストをスクロールしてHQIの低いスペクトルを選択し、[引き算]ボタンをクリックして引き算をします。その後、[Join-Split]ボタンをクリックすると、ヒットリストの表示がおかしくなることがあります。
12 ピークタブの[リセット]ボタンは動作しません。
13 サドラーライブラリのうち、HA(Hummel Surfactants)とRDは使用できません。
14 ユーザーライブラリを新規に作成する場合は、『データ間隔』は、2cm-1、または、4cm-1に設定してください。
15 Windows Vista上で、検索タブにある「追加」ボタンを使って追加登録するとき、表示されるファイル選択ダイアログボックスに拡張子が「*.idx2」であるファイルも表示されますが、必ず拡張子が「*.idx」であるファイルを選択してください。
16 要素の多いライブラリや、多くのライブラリを同時に使用して何度も繰り返し検索を実行すると、IRsolutionが終了してしまうことがあります。
17 日本語を含むファイル名のライブラリを作成して使用すると、IRsolutionが終了してしまう可能性がありますので避けて下さい。

定量関連
1
多点・重回帰・PLS定量結果(Multi Point/MLR/PLS Calibration)を[ファイル]-[エクスポート]コマンド、または、ツリービューのコンテキストメニューから[エクスポート]を選択してもエクスポートできません。
2 濃度を入力していない検量線用スペクトルから『使用』のチェックマークを外した状態では、検量線の計算はできません。使用しない場合でも何らかの数値を入力してください。
3 GLPモードで、定量計算を行なったとき自動的に保存されていても、未保存の状態になることがあります。

AIM/Mapping/3D
1 3次元/4次元データの処理に関して
コンピュータによっては、3次元/4次元データを処理する際にメニュー選択、データ処理など矢継ぎ早に操作を行なうと、IRsolutionがロックする などの症状が出ることがあります。これは、ディスプレイドライバの処理が追いつかない為に起こる現象と考えられます。大容量のデータを扱う場合には確実に 一つの処理が終了してから次の動作を開始してくださるようお願いします。
2 3次元グラフの印刷では、現在バージョンでは、注釈など印刷されませんのでご注意ください。
3 プレビュー測定の画面で、左上の1画が白くなることがあります。画面の描画更新を行なうことで解決します。
4 マッピング測定をご使用される場合、巨大なデータを扱う為、大量のコンピュータメモリを使用します。 メモリが不足すると、カーソルなどの動きが遅くなるなどの現象が発生します。 動作スピードが要求される場合には、メモリを十分に増設してくださるようお願いします。
5 スペクトル検索実行後にマッピングプレビュースキャンを行なうと、マウスポインタが虫眼鏡になる場合がありますが通常の操作には支障ありません。
6 4Dデータから2D、3Dスペクトルを抽出する場合に、抽出ボタンがグレイ表示になる場合がありますが、動作には支障ありません。
7 マッピングのバックグラウンド測定中に測定キャンセルを行なうと、測定パラメータの変更ができません。 測定パラメータを変更するには、サンプル測定実行中にキャンセルを行なうようご注意ください。
8 AIM のエリアマッピングが Ready の状態では IRsolution を終了することはできません。IRsolution を終了する為には、 OK を押して、エリアマッピングを完全に終了してください。
9 マッピングデータを線表示で3次元表示することはできません。
10 グラフの設定でマッピングデータの色設定を変更した後、OKボタンを押しても、変更されません。一度、データの拡大縮小をしてください。
11 ラインマッピングデータを3次元表示したとき、波数軸が通常と逆に、左から右に向かって波数が大きくなるように表示されます。
12 3次元表示されているマッピングデータを拡大したとき、全体表示画面に拡大された領域が表示されません。
13 スペクトル重ね描き表示されたマッピングデータで、[グラフ]-[カーソル]-[サーフィン]を選ぶと、クロスヘアカーソルモードになります。
14 IRsolutionの「AIM」画面で初期化を行なうときに、AIM-8800のレボルバーに標準反射対物鏡をセットしておかないと初期化できません。
15 マッピングデータ同士の重ね描きはできません。
16 1000点を超える測定点のマッピングデータを開くときや閉じるときに時間がかります。
17 マッピングデータを重ね描き表示にした時、スペクトルの色を変えられません。マッピングデータを重ね描き表示した場合、全てのスペクトル が同じ色で表示されます。[環境設定]−[グラフ設定]で色を変えると全ての色が変わり、個々のスペクトルの色を変えることはできません。
18 マッピングデータを重ね描き表示で印刷ができません。マッピングデータを重ね描き表示した場合、印刷しても、その直前に使用していた3次元表示モードか強度分布表示モードで印刷されます。

印刷関連
1 グラフ設定におけるスペクトルの線の太さの変更は、印刷時にはアクティブなスペクトルに対してのみ有効です。
2 凡例や、注釈などがついたグラフをプレビューすると、プレビュー画面では文字が非常に小さく表示されますが、印刷する場合には正常な大きさに印刷されます。
3 [グラフ]-[注釈]でスペクトル上に描いた線や文字が拡大時、縮小時、印刷でその位置がそれぞれ異なります。試し印刷をしてください。
4 検索後、未知スペクトルとヒットしたスペクトルを別々のスケールに拡大して印刷をしても、同じスケールで印刷されます。
5 PLS定量・MLR定量で複数のPrediagnostics、PLS Diagnosticを同時に印刷することはできません。

表示関連
1 スペクトルを重ね描きした後に、元に戻すと、操作によっては、タブ上のスペクトル名が重複する場合があります。 クリア後に再表示してください。
2 「グラフの設定」中で Style タブのグラフ種類の選択はアクティブなデータに対してのみ有効です。また、測定や、印刷などを行い、グラフが更新された後には、設定はデフォルトに戻ります。この機能は仕様として作られています。
3 「グラフの設定」-「Style(スタイル)」で[Set default Values (デフォルトに設定)]ボタンをクリックしたとき、インストール時に「Fill Peaks(ピークの塗りつぶし)」が無効であっても、有効になります。
4 「グラフの設定」-「Advanced (高度な設定)」で[Set default Values (デフォルトに設定)]ボタンをクリックしたとき、「Default view values (デフォルトの表示範囲)」の値は初期値には戻りません。
5 「グラフの設定」-「Coloring (色)」で[Set default Values (デフォルトに設定)]ボタンをクリックしたとき、「Active Object Color (アクティブなオブジェクトの色)」は初期値には戻りません。
6 [ウインドウ]-[マルチウインドウ]-[横に分割]または[縦に分割]が実行された状態で、表示されているスペクトルを閉じた際、過去に表示されていて 閉じたスペクトルタブが表示されることがあり、このスペクトルタブをクリックするとプログラムがロックする場合があります。
7 表示タブ画面のピークテーブルでピーク検出結果をコピーして、貼り付けても貼り付けられず、未保存となります。
8 シフト表示の際に[全てフルスケール]や[マルチオートスケール]をすると縦軸範囲とともにシフト量も変化します。
9

表示画面上で、ピークテーブルとパラメータを表示した状態で、それらの領域を右へ狭くして見えなくするとプログラムがロックする場合があります。

10 多数のスペクトルを閉じたり、重ね描きをするときに時間がかかります。
11 「データ処理1」の「ピーク規格化」のように、垂直カーソルを左右に動かして波数を指定する画面操作のあるものは、Windows Vista上では、画面の解像度や表示色の設定によっては移動中のカーソルが見にくい場合があります。カーソルを停止させて波数値を確認してください。

管理機能
1 表示制限(たとえば過去xx行など)している時にログをエクスポートすると、表示されているログのみがエクスポートされます。
2 ユーザーIDでは大文字と小文字を区別していますが、OSでは大文字と小文字の区別ができないため、このようなユーザーIDは使用しないでください。
3 ロックアウト中のユーザーアカウントが、ロックアウトのままパスワード有効期限が切れるとが起きるとログインができなくなります。このような場合、一旦、このユーザーアカウントを無効化し、再度有効化すると、ロックアウトの解除が可能になります。

マクロ関連
1 マクロプログラムでデータ処理をして同じファイル名で保存すると、内容が壊れてアクティブポインタが不正なものになることがあります。

2011.07.11.